Sintonizadora de TV en Ubuntu

En mi sobremesa tengo una sintonizadora de TV bastante antigua que Ubuntu Dapper reconoce pero no configura correctamente. Al iniciar el sistema me carga el modulo bttv pero no establece los parámetros correctos, que en mi caso seria:

bttv tuner=0 radio=0 pll=1 card=37

Por tanto para hacerla funcionar tenia que hacer:

# rmmod bttv
# modprobe bttv tuner=0 radio=0 pll=1 card=37
# modprobe saa5249

El modulo “saa5249” es para que funcione el teletexto.

Evidentemente lo ideal es configurar el sistema para que cuando me cargue el módulo al inicio, coja los parámetros correctos… así que pensé en editar el fichero “/etc/modules”. Aquí se indican todos aquellos módulos que queremos que se carguen al inicio del sistema de forma obligada (tanto si detecta el dispositivo como si no), así que añadí al final del fichero:

bttv tuner=0 radio=0 pll=1 card=37
saa5249

Reinicie y por desgracia… como Ubuntu detecta por ella misma que debe cargar el modulo bttv, ignora la linea correspondiente del /etc/modules y en consecuencia, seguía cargando los parámetros incorrectos 🙁

Después de dar vueltas por el sistema, me decidí a editar “/etc/modprobe.d/options” y añadir al final:

options bttv tuner=0 radio=0 pll=1 card=37

Borré del archivo “/etc/modules” la linea de bttv (pero si dejando el modulo del teletexto) y reinicie… y tachan! Parece que para indicar opciones de módulos, ese era el fichero correcto 🙂

Para ver la televisión utilizo el programa “tvtime” y para el teletexto “alevt” (que tengo que ejecutarlo con “alevt -vbi /dev/vbi0”).

4 thoughts on “Sintonizadora de TV en Ubuntu”

  1. hola oye queria ver si no me puedes hechar una mano para hechar a andar mi tarjeta de tv por lo datos que das me parece que es la misma del manual es una pixelview play pro pero hice todo lo de el manual y no jalo anteriormente habia deditado otro archivo el /etc/modprobe.d/bttv y ahi agregue un alias y una configuracion para la tarjeta #modprobe card=37 tuner=6 y me salia un canal pero solo ese no podia cambiar de canal no encontraba ningun otro y ademas no se escuchaba ahora edite los archivos que me dijiste pero no me va nada ni se ve ni se escucha espero me puedas ayudar ya no se que mas puedo hacer agradesco mucho tu ayuda desde ya

  2. hola robert no se te ve nada por que no has seleccionado la sintonizadora correcta ni tu tarjeta de tv correcta

    en sintonizadora debes elejir un valor por ejemplo las tarjetas con sintonizador phillip pueden ser la 2, 17, 43 o 44 y tu tarjeta la debes elijir de una lista de tarjetas soportadas por linux, la mia no aparece en dicha lista pero la dejo en 0 para que la autoreconosca y ahi me va bn

    ejemplo: mi tarjeta es una advantek network con FM , soy de santiago de chile, esto hago para configurarla

    #rmmod bt878
    #rmmod bttv

    #modprobe bttv card=0 tuner=43 pll=1 radio=1

    luego actualizo el archivo module con

    #update-modules

    con eso al reiniciar no desapareceria la conf de tu tarjeta , si aun desaparece agrega las lineas bttv y bt878 al archivo /etc/modules

    para autodetectar canales utiliza el programa kdetv que tambien se puede instalar en gnome o instala el programa tvtime que es uno de los mejores a mi gusto

    #aptitude install tvtime sox

    para el sonido

    #tvtime | sox -r 32000 -w -t ossdsp /dev/dsp1 -t ossdsp /dev/dsp

  3. Hola
    Eh leido lo que publicaste y al parecer sabes bastante sobre sintonizadoras. Por lo tanto espero que me puedas ayudar.
    Mi problema es el siguiente:
    Antes te comento que soy de Argentina- Olavarria
    Adquiri el servicio de internet de Fibertel el cual se maneja con el cableado de Cablevision, es decir, coaxil. Por lo tanto gracias a que tengo una placa sintonizadora de tv Encore, podria ver Tv desde mi pc hibridando (si es que esta palabra existe)el cable coaxil.
    Hice todos los pasos pero mi placa solo reconoce un solo canal, Canal 2. Me podrias decir a que se puede deber este problema
    Gracias

  4. he leido lo que dice john salas puesto que yo tengo la misma tarjeta pero en audio no me corre con las instrucciones que el da por favor si alguien me puede ayudar.
    dice que no encuentra /dev/dsp1

Leave a Reply

Your email address will not be published. Required fields are marked *